Primo Status

Some systems are experiencing issues.

Last updated 15 minutes ago

Network Outage - Richmond AP

15 minutes ago 2026-09-13 08:51 UTC
Investigating
Affected Components: North Taranaki

Investigating

15 minutes ago 2026-09-13 08:51 UTC

We're aware of an outage affecting our Richmond AP in the Inglewood area

Our site team is enroute and will working to resolve the issue asap

Affected components