Network Outage - Maidavale/Bell Block
13 hours ago
2026-09-15 09:18 UTC
Identified
Affected Components: North Taranaki
Identified
13 hours ago
2026-09-15 09:18 UTC
We're aware of an outage affecting our Maidavale site in Bell Block affecting customers in the area. Our site teams are working to replace faulty equipment.